Cisco - Sample Config for Cisco 827 and 837

From ExeWiki
Jump to: navigation, search
ADSL > ADSL Modem Setup Guides > Cisco - Sample Config for Cisco 827 and 837


service timestamps debug uptime

service timestamps log uptime

service password-encryption

! hostname ******TYPE YOUR HOSTNAME HERE******

!

enable secret cisco

!

ip subnet-zero

no ip finger

no ip domain-lookup


!

no ip dhcp-client network-discovery

vpdn enable

no vpdn logging


!

vpdn-group pppoe

request-dialin

protocol pppoe

!

bridge irb

!

!

!

interface Ethernet0

description LAN

ip address x.x.x.x x.x.x.x

ip adjust-mss 1452

no keepalive

hold-queue 32 in

no shutdown

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

dsl operating-mode auto

no shutdown

!

interface ATM0.1 point-to-point

description WAN

pvc 8/35

protocol pppoe

pppoe-client dial-pool-number 1

no shutdown

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ppp chap hostname FNN@state.exetel.com.au

ppp chap password xxxxxxxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

dialer-list 1 protocol ip permit

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

exec-timeout 2 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 2 0

!

scheduler max-task-time 5000

end