Cisco - Sample Config for Cisco 877

From ExeWiki
Jump to: navigation, search
ADSL > ADSL Modem Setup Guides > Cisco - Sample Config for Cisco 877


hostname ******TYPE YOUR HOSTNAME HERE******

!

boot-start-marker

boot-end-marker

!

logging queue-limit 1000

logging buffered 100000 debugging

logging reload alerts

logging rate-limit console 20

enable secret *******************TYPE YOUR SECRET PASSWORD*******************

!

no aaa new-model

!

resource policy

!

clock timezone AEST 10

clock summer-time AEDST recurring last Sun Oct 0:01 last Sun Mar 0:01

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.29

ip dhcp excluded-address 192.168.1.241 192.168.1.255

!

ip dhcp pool dhcppool

import all

network 192.168.1.0 255.255.255.0

dns-server 220.233.0.4 220.233.0.3 219.127.89.34

default-router 192.168.1.1

!

!

ip domain name exetel.com.au

ip name-server 220.233.0.4

ip name-server 220.233.0.3

ip name-server 202.139.83.3

interface ATM0

no ip address

logging event subif-link-status

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description Exetel Internet Network

no snmp trap link-status

pvc 8/35

pppoe-client dial-pool-number 3

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1350

no ip mroute-cache

!

interface Dialer1

description eXeTeL-Network

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip mroute-cache

dialer pool 3

dialer-group 1

no keepalive

no cdp enable

ppp authentication chap callin

ppp chap hostname FNN@nsw.exetel.com.au

ppp chap password *******TYPE YOUR ADSL LOGIN PASSWORD HERE*******

!

ip local pool vpnpool 192.168.1.101 192.168.1.105

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer1 overload

!

!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!SAMPLE PORT FORWARDING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ip nat inside source static tcp 192.168.1.31 3389 interface Dialer1 3389

ip nat inside source static udp 192.168.1.100 8503 interface Dialer1 8503

!

line con 0

password *****TYPE YOUR CONSOLE PASSWORD*****

login

no modem enable

transport output all

line aux 0

transport output all

line vty 0 4

access-class 99 in

exec-timeout 20 0

password *****TYPE YOUR TELNET PASSWORD*****

login

transport input all

transport output all

!

scheduler max-task-time 5000

!

end